top of page


Public·73 members
Christopher Robinson
Christopher Robinson

The Perfect Server €? Debian 10 (Buster) With Apache, BIND, Dovecot, PureFTPD And ISPConfig 3.1 ~REPACK~

However, I've seen on -amavisd-with-rspamd-in-ispconfig/ that redis is needed as well, so I tried also that approach, and it worked as well.By: till Reply It does not propose Rspamd configuration, it does the exact opposite, it proposes to not configure Rspamd which is the right choice as it's not installed. So you should have chosen 'n' here as suggested by the installer as this setup uses amavisd and not rspamd. That the setup works nonetheless of choosing 'y' here is because it uses amavisd and Rspamd is not in use.By: Nikolay Reply Hey @till,What about rspamd ? I thought that the new tutorial will have info about rspamd migration/installation.ThanksBy: Hodge555 Reply I've tried the Perfect Server Buster build on 2 new servers and all seems well until I get to ISPConfig. I start that and it's OK until I get info messages that the relevant services are not detected:[INFO] service Apache not detected[INFO] service nginx not detected[INFO] service Postgrey not detected[INFO] service Postfix not detected[ERROR] Postfix not installed - skipping Mail[INFO] service Jailkit not detected[INFO] service pureftpd not detected[INFO] service BIND not detected[INFO] service MyDNS not detected[INFO] service OpenVZ not detected[INFO] service Ubuntu Firewall not detected[INFO] service Bastille Firewall not detected[INFO] service Metronome XMPP Server not detectedbut when I check the services it looks like they are there and on.sudo service --status-all [ - ] apache2 [ - ] apache-htcacheclean [ + ] apparmor [ + ] avahi-daemon [ + ] bind9 [ + ] dovecot [ + ] fail2ban [ + ] haveged [ + ] mysql [ + ] nginx [ + ] nmbd [ + ] ntp [ + ] openbsd-inetd [ + ] php7.3-fpm [ + ] postfix [ + ] postgrey [ + ] pure-ftpd-mysqlAny ideas?By: till Reply Either you are not logged in as root user when you start the ISPConfig installer or you used 'su' instead of 'su -' to become root, see first chapter of this guide or the PATH variable settings of your base system are completely messed up so that no binaries can be found by using the which command on your server. If you need further help, please post in the ISPConfig forum here at howtoforge.By: hodge555 Reply thanks for the prompt response.By: jay Reply Thanks for this tut.I've got some weird behaviour with the webmail settings though:When opening :8081/webmail, the adress changes itself into :8081/squirrelmail and then returns an error that states: "CONFIGURATION ERROR, was not found. Please read the INSTALL instructions!"Even though I installed Roundcube following your tutorial and the browser tab even says "Roundcube Webmail".File /etc/roundcube/ exists and is readable...Any idea what went wrong?By: Slayer Reply I got the same error.nginx log error: file_put_contents(/var/log/roundcube/errors): failed to open stream: Permission denied in /usr/share/roundcube/program/lib/Roundcube/rcube.php on line 1259PHP message: PHP Warning: SQLSTATE[HY000] [1045] Access denied for user 'roundcube'@'localhost' (using password: NO) in /usr/share/roundcube/program/lib/Roundcube/rcube.php on line 1364PHP message: PHP Warning: file_put_contents(/var/log/roundcube/errors): failed to open stream: Permissão negada in /usr/share/roundcube/program/lib/Roundcube/rcube.php on line 1259PHP message: PHP Warning: was not found. in /usr/share/roundcube/program/lib/Roundcube/rcube.php on line 1364"I checked in mariadb and database, user and pass created successfully. By: Abdul Reply The /etc/roundcube folder has weird permissions. Reverting them to normal fixes the issue as seen in =16995#p75838: However, I did a more standard chmod:sudo find /etc/roundcube -type f -exec chmod 664 \;sudo find /etc/roundcube -type d -exec chmod 775 \;sudo find /etc/roundcube -type d -exec chmod g+s \;By: OsmDroid Reply thanks so much for postfix-sasl changes in fail2ban. It really messes up mail.log with constant spam. Perfect server guides are best

The Perfect Server – Debian 10 (Buster) with Apache, BIND, Dovecot, PureFTPD and ISPConfig 3.1


By: Sergey Reply Debian 10 with Nginx + php-fpm please :)By: Roffe Reply Hi I have installed debian buster and roundcube but how do i get plugins to work have look at this ISPConfig 3 Roundcube Plugin on Debian 9 (Stretch) but don't know if it works with debian 10 (Buster)By: till Reply Install them and then you know if they work with PHP 7.3. I have not tested them. Or contact their author and ask him.By: ffab Reply this is great. works perfectly !could you consider explain using a valid let's encrypt cert for ispconfig admin interfaceregards,By: Jose Reply I used this works like a charmBy: Michal Reply Hi,Do anyone have issue with "Update Packagelist"?I'm getting information: "No packages to read in"I run this update on 3 servers and i have this same issue.By: thctlo Reply Hai, Thanks for this update again, great! Is it an option to replace phpmyadmin with adminer or phpliteadmin from debian itself, i preffer to have minimal source packages and same for certbot. Or are there then things going wrong with ispconfig? I want that because of the security updates. By: till Reply PHPMyadmin is not required for ISPConfig, so feel free to replace it or leave it out. Regarding certbot, you can use the certbot package from Debian but Debian will not keep it up to date and this will cause you issues in a few months or years. We have seen these problems in Debian 9. That's why we recommend to not use the Debian package for Certbot, better get the latest Certbot version and keep it up to date with certbot-auto.By: thctlo Reply Hai Till, thank you for you reply, most welkom. I did a few runs for the install and I have some corrections/additions to the above setup. 7) ntp, not needed to install see : timedatectl is save a bit space and packages to install/maintain. 8) Dovecot : # fix is very simple: adduser dovecot dovecotThat was all i did and the error is gone in my logs. Extra Add dovecot DH params. openssl dhparam -out /etc/ssl/private/dovecot-dhparams.pem 2048chown root:dovecot /etc/ssl/private/dovecot-dhparams.pemchmod 640 /etc/ssl/private/dovecot-dhparams.pem# and add the DH parameter to the config. sed -i '/ssl_key =

In the error message I have pasted here before, obviously I replaced my real domain for "myweb" and my personal gmail email for "mypersonalemail" for privacy.Could you help me? I bought the ispconfig manual, but I don't know the best way to set up an email for a domain.I have to tell you that as the use of ispconfig, it will be personal, I have not created any client, or any reseller.Thank you Till!By: till Reply Hi Mark, please post your support question in the iSPConfig forum so we can help you figure out what the problem with your mail server setup is: -3.23By: Bakha Reply I have a problem with pureftpd when create users ftp not working (can not connect)fix it please or please double-check the commandsBy: till Reply Tested it today, the tutorial is working öperfectly, nothing to be changed. Your problem is not related to an issue in this tutorial. When you can't connect to FTP then you either did not follow the tutorial closely or you have closed the FTP ports in an external firewall or used a wrong IP or hostname to connect or something similar. Please post in the ISPConfig forum here at howtoforge if you need further help to find out what's wrong with your server.By: Hendrik57 Reply Perhaps things are changed with Debian 10 distibution.I've got the same errors. Https and Https work, but ftp not. And I copied all lines to avoid mistyping on a new Debian 10 install (14 dec 2019 download)With a deactivated UFW, only ports 80 and 443 respond. Port 21 is closed.Activating UFW makes all ports close, including 80 and 443.After I did:ufw allow ftpufw allow sftpufw allow httpufw allow httpsI could login and sites on 80 and 443 work with Letsencrypt certificate on the website.I could login with FTP, but it seems to hang in getting the folderlist. Login was succesfull.By: Fenna Reply Thx for another update on this concept of seting up a server system. Been using these tutorials for years and always happy with the result. This incarnation is no different :)By: Fabrice Reply Hi All,After the installation on Debian10, I can't send an email thru php (Wordpress).Command mail doesn't exist.I put SMTP information in ISPConfig for roundcube (works for roundcube)Thanks FabriceBy: Eric Reply Hi,I tried the install, great work. However, I did skip some steps and modified a few. tks.By: Nick Reply Hi TillPerfect servers through perfect tutorials. However I have a big stone in my shoe and its called Amavis crap. I have 4 separate hardware HP servers all running beautifully however amavis crashes on all 4 of them at irregular intervals and has to be restarted every now and then even at boot. This piece of crap software would keep all the emails hostage to its wellbeing and have to keep an eye on it every hour to make sure it doesnt crash. Please advise work-around pls.By: Nick Reply I have upgraded from stretch to Buster and have faced a lot of ssl dovecot problems which I uninstalled and reinstalled however ISPConfig does not seem to be able to update user mail and other records. Do I need to reinstall ISPConfig or follow any of the above steps again?By: till Reply Do not uninstall ispconfig as you would not be able to install it again without loosing all config. Follow the above guide to ensure all packages are installed and then run an ispconfig update with reconfigure services = yes. If you need further help, post in the ISPConfig support forum here at howtoforge.By: Eric Reply That is 'pma' ? Is this a user name you created?By: Leighton Walters Reply This tutorial is quite straightforward and error-free. I was able to complete it without any errors in one attempt. Five stars!By: Anahata Reply I completed the installation, but when I visit the control panel, Firefox refuses to connect because it doesn't trust a self-signed certificate, and won't allow an exception because of HSTS. Chrome does the same.The only thing I did different was to set the password to something more secure than 'admin' during the install, but I don't expect that to be a problem.I uninstalled and re-installed ispconfig, with the same result.By: till Reply The warning that you see is caused by the self-signed SSL certificate, that#s ok and not an installation issue, you can simply accept the warning in the browser to proceed. Or you install another SSL cert for ISPConfig if you have already one for the hostname of the server or you install one from Let's encrypt: -ispconfig-3-with-a-free-lets-encrypt-ssl-certificate/By: Anahata Reply No, the browser won't let me "accept the warning" and continue because of HSTS. Even if I tell Firefox to 'forget' the site (which should clear the HSTS setting) it's the same. I've commented out the apache2 ispconfig.vhost settings relating to Strict Tranport Security and Content Security Policy and that hasn't helped either.The instructions you linked to, for LetsEncrypt, seem to assume I have a working ISPConfig panel, which I don't. I'll try the shell commands to symlink the Letscrypt certificate data to /usr/local/ispconfig/interface/ssl, but I've already tried that once and it didn't work. By: till Reply Accepting the error message usually works, I install this setup several times a week using self-signed certificates and I'm always able to accept the self signed cert in all major browsers, so your problem is not this setup and not the settings of the ispconfig vhost. Your problem is probably the domain that you use for the server hostname, if you used that domain or subdomain before and used it with hsts, then your browser will block it if you reuse it with another cert now, no matter of the settings in ispconfig vhost. If you can't login by ssl, disable ssl in the vhost, login by http, create the LE based vhost and follow the guide that I posted the link to and then enable ssl in the vhost again.By: Anahata Reply Thank you - you are absolutely right, the browser has visited the main domain and other subdomains with HSTS and after I cleared all its memory of them, I was able to reach the ISPconfig panel.By: Bertrand Reply Great tutorial ! thank you, it just misses the package patch to launch the install of ISPConfigBy: till Reply The patch package is installed if you followed all steps. You probably left a step out (most likely jailkit) if patch was missing on your system.By: Jawad Reply Hello, thank you for supportI can send email using roundcube, but i cant recive it from external.i sent it only from internal sending from [email protected] to [email protected] for example.thank you By: Jeff BRyner Reply Good install, all went well. One "Feature" Id like to control is that if you go to the IP address of the server it bypasses any available site on the ISPConfig system and dumps to a default page served by Apache. Is there any way to control this or eliminate it?By: till Reply That's the way an apache web server is working, so that's not ISPConfig specific. You have to use either * or the Ip for all sites that use the same IP in DNS, don't mix it. If you don't want to use IP addresses in apache, delete the IP under System > Server IP.By: Paolo Reply Reading the howto it seems that Mailman 2.x is used.. Is it possible to upgrade to Mailman 3.x or Ispconfig needs some module rewriting before using the latest version?By: Jawad Reply HiPlease, I install ISPConfig according this guide, All is ok, but i have 2 Address IP, I add the 2nd IP in /etc/network/interfaces before installation, and the ISPConfig has detect the both IP. but i want to make all website work with 2 ip. for my principal domain I make dns as :NS1 : with IPv4(1)NS2 : with IPv4(2)NS3 : with IPv6by default whene i put (in the browser) the 1st IPv4, i get my website, but if i put 2nd IPv4 i get Apache2 Debian Default Page.Please, how to make the 2nd IPv4 as secondary IP for all website.Thank youBy: till Reply Choose * in the IPv4 field for all sites instead of the first or second IP address.By: Jawad Reply Thank you Mr TILLI change it, but allways show default apache page for the 2nd IPBy: Mike Conom Reply Hi,Can you tell me what is better for hostnameI have a vps server as


Welcome to the group! You can connect with other members, ge...


  • Jeremy Tang
  • Adelina Chauchescu
    Adelina Chauchescu
  • Ra He
    Ra He
  • Love
bottom of page